|
Hello. Our service runs in Kubernetes and uses the http and jobs plugins to operate. When deploying we catch an error: "jobs_plugin_push: no such pipeline ..." in terminating pods. Could the issue be related to the order of plugin shutdown? Or do you have any other ideas? |
Answered by
rustatian
Jun 24, 2025
Replies: 1 comment 2 replies
|
Hey @saxap 👋🏻 Shutdown does not have a specific order; only startup does. You can get this error because of the following reasons:
|
2 replies
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Yeah, that can happen when you're still pushing data to the pods while terminating them. You may first stop all pushers/senders/whatever that send data via RPC to this POD, and then terminate it.
And yeah, on the RR side, you can't do much with that.