Skip to content

Failed uxm_relock often followed by initialize in tune block #242

Description

@ktcrowley

In schedule 874 on SATp2, beginning at ~2300 on 10/29/2025, a relock call crashed for slot c5s5. The stdout within the nextline service reports that this slot then gets dropped from targeted SMuRF calls, but because the next commands for detector tuning follow a run.initialize() call, this slot gets its detectors tuned despite the readout not being in a usable state.

This issue could apply in general where slots that have a failed det_controller action get repeatedly polled to reset their "target" status the next time a tune block appears in the schedule. However, a slot without relock will never recover without that command being rerun, which doesn't happen every tune block. The data of the problem slot won't be useful for any detector tuning or sky observations, and likely shouldn't be streamed.

Would there be away to make a two-tier target system, one for relocks, and the other for detector tunings? This may not be critical if SATp2 slot issues stabilize first, but may still be useful whenever issues with relock commands crop up.

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions